晓夏

新手菜鸟Linux学习之路

不怕从零开始,只怕从未启程

关于centos7.2安装docker-ce问题(需指定版本)

浏览量:516

今天遇到个特别奇葩的问题。在docker run的时候发现出现如下问题。


操作系统:centos 7.2
内核:3.10.0-327.el7.x86_64
docker版本:docker-ce 18.09.2

image.png


image.png

解决方法: 
yum remove docker-ce docker-ce-cli containerd.io        #删除原有的

yum install -y docker-ce-18.09.0-3.el7 docker-ce-cli-18.09.0-3.el7 containerd.io-1.2.0-3.el7    #安装低版本的docker-ce



验证问题是否解决:

image.png

docker新安装版本:

image.png

分享:

支付宝

微信